文章详情

股旁网!通达信财务副图指标公式源码

时间:2020-01-08 11:17来源:未知 作者:股票公式指标网 点击:
DRAWTEXT_FIX(CONST(INDEXC)DRAWTEXT_FIX(1,0.87,0.85,1,'公式共同交流————理想论坛(偷不到就抢)'),COLORYELL

DRAWTEXT_FIX( CONST(INDEXC)

DRAWTEXT_FIX(1,0.87,0.85,1,'公式共同交流————理想论坛(偷不到就抢)'),COLORYELLOW;

DRAWTEXT_FIX( CONST(INDEXC)

DRAWTEXT_FIX( CONST(INDEXC)>SAR(4,2,20),0.95,0.11,1,'∧∧∧∧'),COLORRED;

DRAWTEXT_FIX( CONST(INDEXC)>SAR(4,2,20),0.95,0.16,1,'∧∧∧∧'),COLORRED;

DRAWTEXT_FIX(1,0.96,0.01,1,':'),COLORRED;

DRAWRECTREL(970,670,580+CONST(获利筹码*(970-580)/100),740,RGB(0,100,0));

DRAWRECTREL(970,470,580+CONST(活跃度比*(970-580)/100),540,RGB(0,100,0));

DRAWRECTREL(970,340,580+CONST(量能饱和*(970-580)/100),270,RGB(0,100,0));

DRAWRECTREL(970,670,580,740,RGB(150,10,250));

DRAWRECTREL(970,470,580,540,RGB(150,10,250));

DRAWRECTREL(970,340,580,270,RGB(150,10,250));

DRAWTEXT_FIX(1,0.74,0.55,1,STRCAT(STRCAT('获利筹码:',CON2STR(获利筹码,2)),'%')),COLORYELLOW;

DRAWTEXT_FIX(1,0.74,0.35,1,STRCAT(STRCAT('活跃度比:',CON2STR(活跃度比,2)),'%')),COLORYELLOW;

DRAWTEXT_FIX(1,0.74,0.15,1,STRCAT(STRCAT('量能饱和:',CON2STR(量能饱和,2)),'%')),COLORYELLOW;

活跃度比:=IF(活跃>=0,(活跃+100)/2,100-ABS((活跃-100)/2));

活跃:=(WRSI-WR10);

WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;

饱和:=(IF(SAT>1,1,SAT)*100);

SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));

获利:=CONST(WINNER(C)*100);

W:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;

LC:=REF(CLOSE,1);

DRAWTEXT_FIX(Z值>2.6,0.838,0.11,1,' ◎无 警◎'),COLORLIGREEN;

DRAWTEXT_FIX( BETWEEN(Z值,1.2,2.6),0.838,0.11,1,' ○轻警○'),COLOR0099FF;

DRAWTEXT_FIX(Z值<1.2,0.838,0.11,1,' ●重 警●'),COLORLIRED;

DRAWTEXT_FIX(1,0.85,0.01,1,'财务:'),COLORRED;

Z值:=X1+X2+X3+X4+X5;

X5:=FINANCE(20)/FINANCE(15)*0.999;

X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}

X3:=FINANCE(23)/FINANCE(10)*3.3;

X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替}

X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;

{风险系数}

DRAWNUMBER_FIX(1,0.57,0.75,1,每股公积金),COLORWHITE;

DRAWNUMBER_FIX(1,0.57,0.65,1,每股未分配),COLORWHITE;

DRAWNUMBER_FIX(1,0.57,0.55,1,每股现金流),COLORWHITE;

DRAWNUMBER_FIX(1,0.57,0.45,1,每股收益年),COLORWHITE;

DRAWNUMBER_FIX(1,0.57,0.35,1,每股收益季),COLORWHITE;

DRAWNUMBER_FIX(1,0.57,0.25,1,市销率),COLORWHITE;

DRAWNUMBER_FIX(1,0.57,0.15,1,市净率),COLORWHITE;

DRAWTEXT_FIX(1,0.51,0.75,1,'每股公积金:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.51,0.65,1,'每股未分配:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.51,0.55,1,'每股现金流:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.51,0.45,1,'每股收益年:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.51,0.35,1,'每股收益季:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.51,0.25,1,'市销率 :'),COLORYELLOW;

DRAWTEXT_FIX(1,0.51,0.15,1,'市净率 :'),COLORYELLOW;

每股公积金:=CONST(FINANCE(18));

每股未分配:=CONST(FINANCE(32));

每股现金流:=CONST((FINANCE(25)/FINANCE(1)));

每股收益年:=CONST(FINANCE(33));

每股收益季:=CONST(FINANCE(33)/(5-FINANCE(37)));

市销率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));

市净率:=CONST(DYNAINFO(7) / FINANCE(34));

DRAWTEXT_FIX(1,0.498,0.01,1,'财务指标:'),COLORRED;

DRAWNUMBER_FIX(1,0.4,0.75,1,净利同增率),COLORWHITE;

DRAWNUMBER_FIX(1,0.4,0.65,1,现金负债比),COLORWHITE;

DRAWNUMBER_FIX(1,0.4,0.55,1,优质资产率),COLORWHITE;

DRAWNUMBER_FIX(1,0.4,0.45,1,主营利润率),COLORWHITE;

DRAWNUMBER_FIX(1,0.4,0.35,1,净利润比率),COLORWHITE;

DRAWNUMBER_FIX(1,0.4,0.25,1,销售毛利率),COLORWHITE;

DRAWNUMBER_FIX(1,0.4,0.15,1,净资收益率),COLORWHITE;

DRAWTEXT_FIX(1,0.34,0.75,1,'净利同增率:'),COLORYELLOW

DRAWTEXT_FIX(1,0.34,0.65,1,'现金负债比:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.34,0.55,1,'优质资产率:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.34,0.45,1,'主营利润率:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.34,0.35,1,'净利润率 :'),COLORYELLOW;

DRAWTEXT_FIX(1,0.34,0.25,1,'销售毛利率:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.34,0.15,1,'净资收益率:'),COLORYELLOW;

净利同增率:=FINANCE(43);

现金负债比:=(FINANCE(25)/FINANCE(15));{缺长期负债或负债总额,编辑:股旁网,

优质资产率:=((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19));{理论上越大越好但不同行业有不同标准};

主营利润率:=(FINANCE(23)/FINANCE(20)*100);

净利润比率:=(FINANCE(30)/FINANCE(20)*100);

销售毛利率:=((FINANCE(20)-FINANCE(21))/FINANCE(20)*100);

净资收益率:=(FINANCE(33)/FINANCE(34)*100);

DRAWTEXT_FIX(1,0.326,0.01,1,'业绩指标:'),COLORRED;

DRAWTEXT_FIX(1,0.23,0.75,1,'股'),COLORCYAN;

DRAWTEXT_FIX(1,0.23,0.65,1,'人'),COLORCYAN;

DRAWTEXT_FIX(1,0.23,0.55,1,'亿元'),COLORCYAN;

DRAWTEXT_FIX(1,0.23,0.45,1,'亿元'),COLORCYAN;

DRAWTEXT_FIX(1,0.23,0.35,1,'天'),COLORCYAN;

DRAWTEXT_FIX(品种类型=3,0.23,0.15,1,' 创 业 板'),COLORMAGENTA;

DRAWTEXT_FIX(品种类型=2,0.23,0.15,1,' 中 小 板'),COLORMAGENTA;

DRAWTEXT_FIX(品种类型=1,0.23,0.15,1,'沪 深 A 股'),COLORMAGENTA;

DRAWNUMBER_FIX(1,0.2,0.75,1,人均持股),COLORWHITE;

DRAWNUMBER_FIX(1,0.2,0.65,1,股东人数),COLORWHITE;

DRAWNUMBER_FIX(1,0.19,0.55,1,流通市值),COLORWHITE;

DRAWNUMBER_FIX(1,0.19,0.45,1,股总市值),COLORWHITE;

DRAWNUMBER_FIX(1,0.2,0.35,1,上市天数),COLORWHITE;

DRAWTEXT_FIX(1,0.23,0.25,1,HYBLOCK),COLORLIGREEN;

DRAWTEXT_FIX(1,0.14,0.75,1,'人均持股:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.14,0.65,1,'股东人数:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.14,0.55,1,'流通市值:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.14,0.45,1,'股总市值:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.14,0.35,1,'上市天数:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.14,0.25,1,'所属板块:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.14,0.15,1,'品种类型:'),COLORYELLOW;

人均:=ROUND(FINANCE(7)/FINANCE(8));

股东人数:=FINANCE(8);

流通市值:=ROUND(FINANCE(40)/);

股总市值:=ROUND(FINANCE(41)/);

上市天数:=FINANCE(42);

所属:=HYBLOCK;

品种类型:=FINANCE(3);

DRAWTEXT_FIX(1,0.14,0.01,1,'股份:'),COLORRED;

DRAWRECTREL(0,0,990,990,RGB(20,18,12));

{以上公式指标有 精选股票公式指标网 收集整理  我们的网站是 www.jxwgs.com}

 

Tag标签:IN(25227)收益(278)活跃(139)BE(1082)负债(72)

------分隔线----------------------------
下载提示
本站所有资源均来自网络,并永久免费下载。任何个人或团体不得利用本站资源进行商业性活动,否则后果自负,本站不负任何责任。